L’arrivée de la v4.7 a un impact sur le support des anciennes versions

Bulletin technique K2[5 juin 2017 – Mise à jour de l’article suite à la modification du bulletin technique]

La version 4.7 de K2 va bientôt être disponible, et comme il s’agit d’une version importante (elle ouvre la voie à une nouvelle branche), cela va avoir un impact sur le support des différentes versions de K2.

Un bulletin technique complet sur le sujet vient d’être publié, mais prenons quelques minutes pour en faire ressortir les points importants.

Tout d’abord un petit rappel de la nomenclature des versions K2 et des différentes versions K2 aujourd’hui supportées :

  • nomenclature des versions K2 X.Y.z :
    • X est le numéro de version majeure
    • Y est le numéro de version mineure
    • z est le numéro de mise à jour
    • une mise à jour n’est pas que corrective, elle apporte aussi son lot de nouvelles fonctionnalités (connecteurs, contrôles etc.) et de support de nouvelles versions de produits intégrés
  • branche 4.5 :
    • date de sortie initiale : avril 2010
    • nombre de mises à jour : 14
    • version actuellement supportée : la dernière de la branche
  • branche 4.6 :
    • date de sortie initiale : avril 2012
    • nombre de mises à jour : 12
    • versions actuellement supportées : toutes
  • version actuelle :
    •  4.6.11 : sortie en septembre 2015
    • dernière version de la branche 4.6

La sortie de la version 4.7.0 attendue pour le trimestre prochain va mettre fin au support de la branche 4.5, puis nous allons rentrer en phase de sunset pour la branche 4.6 : la version 4.6.11 va devenir la seule version de la branche supportée pour une période de 2 ans depuis sa date de sortie (à savoir jusqu’en septembre 2017). [mise à jour du 15 juin 2016 : ] Il a finalement été décidé de prolonger le support de la version 4.6.10, qui sera donc valable jusqu’au 24 juin 2017 (ce qui est une bonne nouvelle).

A partir de la sortie de la 4.7, peu importe la version que vous utilisez, vos plateformes continueront à fonctionner  mais il ne sera plus possible de faire appel au support ou obtenir des correctifs pour les versions inférieures à la 4.6.11 4.6.10. Il est donc important de penser sérieusement à mettre à jour vos environnements.

N’hésitez pas à rentrer en contact avec vos interlocuteurs commerciaux ou techniques pour avoir plus d’informations ou pour planifier la mise à jour de vos environnements.

Happy K2ing !

Bulletins précédents liés à la 4.7 :

jean

Directeur technique de K2 France depuis 2006 et passionné par les technologies, je travaille dans le monde du BPM et des applications métier depuis... que je travaille :). Vous pouvez également me suivre sur twitter, linkedin.

3 thoughts to “L’arrivée de la v4.7 a un impact sur le support des anciennes versions”

    1. Hé hé. Merci Laurent pour votre commentaire. Un tel article est prévu (et pour tout dire, il est même déjà presque finalisé), on attend juste d’avoir l’autorisation de communiquer sur les nouveautés et donc de le publier.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.